通达信主图趋势线指标公式

问:请老师帮忙编写下图主图指标公式,用在通达信版

通达信专用机构通道主图指标公式
M1:=EMA(C,5);M2:=EMA(C,13);M3:=EMA(C,34);
MC1:=EMA(C,55);MC2:=EMA(C,89);MA4:=EMA(C,144);
判势线:=NEWSAR(1,100),COLORYELLOW,LINETHICK2;
牛熊线:IF(MC1>MAX(MC2,MA4),MC1,IF(MC1<MIN(MC2,MA4),MC2,MA4)),COLORFF00CC,LINETHICK2;
AA:=1;
中轨:EMA(CLOSE,17)*AA,LINETHICK1,COLORFFFFFF;
卖出线:中轨+2*STD(CLOSE,17),LINETHICK1,COLOR0000FF;
买入线:中轨-2*STD(CLOSE,17),LINETHICK1,COLOR00CC00;
清仓线:中轨+3*STD(CLOSE,17),LINETHICK1,COLORFF00FF;
满仓线:中轨-3*STD(CLOSE,17),LINETHICK1,COLOR00AA00;
LOCK:=IF(TIME<1160101,1,0);
VARA:=MA(CLOSE,20);
趋势线:IF(VARA>REF(VARA,2),VARA,IF(VARA<REF(VARA,2),VARA,VARA)),COLOR00FF00;
IF(VARA>REF(VARA,2),VARA,DRAWNULL),LINETHICK2,COLORFF00FF;
IF(VARA=REF(VARA,2),VARA,DRAWNULL),LINETHICK2,COLORFF0000;
IF(VARA<REF(VARA,2),VARA,DRAWNULL),LINETHICK2,COLOR00FF00;
买入:IF(VARA>REF(VARA,2) AND REF(VARA<=REF(VARA,2),1),1,0),NODRAW,COLORAAAAAA;
DRAWICON(CROSS(LOW,满仓线),满仓线*0.96,11);
DRAWICON(CROSS(HIGH,清仓线),HIGH,12);
TY:=CLOSE;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
A:=REF(CLOSE,BARSLAST(HD)); B:=REF(CLOSE,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波峰:IF(T1,A,A),COLORFF00FF,POINTDOT;
STICKLINE(T1,A,A,1.5,0),COLORFF00FF;
波谷:IF(T2,B,B),COLOR80FF00,POINTDOT;
STICKLINE(T2,B,B,1.5,0),COLOR80FF00;
MA1:=MA(C,3);
XG1:=MA1>REF(MA1,1) AND REF(MA1,1)<REF(MA1,2) AND C>MA(C,7);
DRAWTEXT(FILTER(XG1,9),LOW*0.97,'B'),COLORRED,LINETHICK2;
DRAWICON(FILTER(XG1,9),LOW*0.98,1);
VAR2:=SUM(IF(CLOSE>OPEN,VOL,0),30)/SUM(VOL,30)*100;
VAR3:=100-SUM(IF(CLOSE>OPEN,VOL,0),30)/SUM(VOL,30)*100;
多头力量:= VAR2;
空头力量:= VAR3;
RSV:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
XG2:=多头力量 > 空头力量 AND 多头力量 - 空头力量>30 AND CROSS(D,K) OR
MA1<REF(MA1,1) AND REF(MA1,1)>REF(MA1,2) AND REF(MA1,2)>REF(MA1,3) AND K>50;
DRAWTEXT(FILTER(XG2,9),H*1.06,'S'),COLORGREEN,LINETHICK2;
DRAWICON(FILTER(XG2,9),H*1.02,2);
{跳空缺口}
LL1:=REF(L,1);
HH1:=REF(H,1);
SQK:=L>HH1;
XQK:=H<LL1;
上跳:IF(SQK=1,L-HH1,DRAWNULL),COLORFF00FF,CROSSDOT,LINETHICK3,NODRAW;
下跳:IF(XQK=1,H-LL1,DRAWNULL),COLORGREEN,CROSSDOT,LINETHICK3,NODRAW;
STICKLINE(SQK,L,HH1,4*1,1),COLORYELLOW;{上跳}
STICKLINE(XQK,H,LL1,4*1,2),COLOR00FF00;{下跳}
DRAWTEXT(SQK,H,'上跳'),COLORYELLOW;
DRAWTEXT(XQK,L,'下跳'),COLOR00FF00;
{补缺口}
K1:=BARSLAST(L>REF(H,1));
K2:=L<REF(H,K1+1) AND COUNT(L<REF(H,K1+1),K1)=1;
STICKLINE(K2,L,O,1,0),COLORFF00FF;{缺口回补};
DRAWTEXT(K2=1,L,'回补'),COLORFF00FF;

问:求通达信画线公式

M3:=EMA(CLOSE,3);
M8:EMA(CLOSE,8),COLOR008000;
M13:EMA(M8,13),COLOR0000FF;
M62:EMA(M8,55),COLORF0F000;
VAR1:=EMA(M13,62);
M81:EMA(M62,81),COLOR00FFFF;
M144:EMA(VAR1,144),LINETHICK2,COLOR0000FF;
M250:EMA(VAR1,250),POINTDOT,LINETHICK2,COLORF00FF0;
MA250:MA(CLOSE,250);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2),4);
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
散户1:EMA(CLOSE,5),COLORWHITE;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,18);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一0.809:REFDATE(H1,DATE),COLORYELLOW;
二0.618:REFDATE(H2,DATE),COLORMAGENTA;
三0.500:REFDATE(H3,DATE),COLORWHITE;
四0.382:REFDATE(H4,DATE),COLORGREEN;
五0.191:REFDATE(H5,DATE),COLORYELLOW;
低:REFDATE(低1,DATE),COLORRED; 源码给你了!加分 你还要等?真是没有意思,原来你是钓鱼。 呵呵做人不够厚道!“如图,类似的也可”??????
你可以不给分算我贡献百度的网站了! 你自己慢慢等吧。

问:请高手中的高手,编写一个通达信的自动画线公式,(包括长期趋势,中短期趋势线)

{N:=75;P:=5;P1:=10; 参数范围1---100}
A1:=REF(H,P)=HHV(H,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短压:DRAWLINE(D1,H,F1,H,1),COLORCYAN,DOTLINE;
A2:=REF(L,P)=LLV(L,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED,DOTLINE;
AA1:=REF(C,P1)=HHV(C,2*P1+1);
BB1:=FILTER(AA1,P1);
CC1:=BACKSET(BB1,P1+1);
DD1:=FILTER(CC1,P1);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
长压:DRAWLINE(DD1,H,FF1,H,1),COLORGREEN LINETHICK2;
AA2:=REF(L,P1)=LLV(L,2*P1+1);
BB2:=FILTER(AA2,P1);
CC2:=BACKSET(BB2,P1+1);
DD2:=FILTER(CC2,P1);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
长支:DRAWLINE(DD2,L,FF2,L,1),COLORRED LINETHICK2;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
突破:C>短压 OR C> 长压,NODRAW;
DRAWICON(突破 AND REF(突破,1)=0,L*0.99,1);
手动调节参数以达到最佳效果,一定要提防假突破。

问:以这个公式为基础,改为通达信选股公式,要求趋势线数值小于1注意是趋势线不是趋势,谢谢大神可以帮忙~

趋势线:= 3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
买入时间: CROSS(趋势线,2) AND REF(趋势线,1)<1;
公式中的是趋势线是上穿2大于你的要求1选不出股票的,你看一下这个合适吗,或者可以把上穿数值调小一点

问:股市中哪个指标最好用?

macd

问:趋势与区间,哪种技术指标最适用?

这是一个很务实的问题,因为,外汇市场即使深受经济趋势主宰,例如货币政策周期,而呈现长期性的趋势性走势,但是,这种方向性的趋势仍仅占市场价格行为的三分之一,意味有大约三分之二的时间,市场价格变化其实是没有方向性可言的。趋势与区间的谜思 更糟糕的是,许多交易者通常仅仰赖一、两种技术指标来辨识市场的方向以及作为交易时机的依据,这种“ 万用型”的取向使得他们经常受困于趋势与区间的市场,因为,适用于辨识市场方向趋势的技术指标在市场呈现区间走势时,可能严重的误导交易者。结果是,交易者可能太早了结获利、错失了一个更大的方向性波段,或是误以为趋势仍在而导致持有一个短线交易太久。 为避免陷入这种到底有没有趋势存在的谜思,本文的目的即在于建议交易者同时使用数个技术指标,以辨识市场是否存在着方向性的趋势,以及使用不同的指标来决定进场、出场点。不过,与其条列出一串交易规则,本文主要将提出一种弹性的技术分析方式,以协助交易者解决市场趋势是否存在的疑虑。适合趋势交易的工具 首先,我们必须定义何谓趋势。从技术分析的观点来看,趋势的含意是价格行为在所谓阻力位与支持位的变化是可预期的。例如,在一个上升趋势中,价格在接近支持位的时候将会反弹,最后会再创新高点;反之,在一个下跌趋势中,价格的回升将受阻于阻力位,最后还是会出现新低点。这个定义其实已经说明,趋势线分析是我们用来辨识趋势是否存在的第一个工具,这种分析并可用来建议所谓的支持位与阻力位。 有些市场人士认为趋势线的分析太过主观,但是他们忽略了一点,这种分析其实有助我们看清础市场隐含的价格型态。有鉴于此,趋势线分析应该是用来决定趋势是否存在的第一项工具,如果该分析并无法显示出一个可以辨认的趋势,很可能的,市场目前便根本没有趋势可言。此外,趋势线分析也可用来辨识价格型态,这些型态本身也具有预测性的价值。 使用趋势线分析最好的出发点是采用较长时间的价格图表,例如日线图或周线图,然后才一步一步缩小至 4 小时以及 1 小时图,如此也可发掘较短线的支持位与阻力位。这种作法可以依序彰显出各种支持位与阻力位的重要性,避免交易者因为遵循了一个较短线的趋势线突破而忽略了一个可能就在不远处的主要趋势线。 另一个较客观的趋势判定工具是方向指标 (DMI,dirctional movmnt indicator),此一指标可以有效排除关于趋势是否存在的疑虑,并进一步确认从趋势线分析所得到的结论。 DMI 系统系由 ADX (aag dirctional movmnt indx) 与 DI+ 及 DI- 两条线所组成,ADX 是用来判断目前市场是否处于趋势性的走势,如果指数高于 25,便意味趋势性的走势存在,低于 20 则意味目前并无趋势可言。 ADX 同时也可用来衡量趋势的强度,指数愈高便意味趋势性愈强。使用 ADX 指标不仅可判断市场是否处于趋势性的走势,更重要的是,交易者可据此决定是否使用趋势追随的交易系统。 DMI 系统的两条线可产生交易讯号,当 DI+ 由下向上穿越 DI- 时,这是一个买入讯号,当 DI- 由下向上穿越 DI+ 时,这是一个卖出讯号,不过如果要确认此一讯号的有效性,讯号当期的最高或最低价必须在下一个期间受到超越。 因此, ADX 可用来做为趋势是否即将停顿的领先指标,当 ADX 开始从高位下降时,原有趋势如果不是停顿便是已经结束,此时交易者将可了结既有的部位,然后等待下一个 DI+/DI- 的交叉交易讯号。区间走势的工具 诸如 RSI 、 Stochastics 或 MACD 这些判定价格势头的震荡指标,是许多交易者最常应用在没有具体趋势或横向走势的市场工具,这些震玛 ? 指标的最主要功能,是显示商品是否具有超买或超卖的迹象,并提前显示可能的价格反转讯号。 然而,一旦市场处于强劲的趋势中,这种势头指标将可长时间地维持在超买或超卖的区间,并促使价格持续走高或走低,使得纯粹仰赖势头指标的交易者不是太早了结获利的头寸,就是反向交易,但是原有的趋势并不因为震荡指标已达极端位置而改变。 给我留言 势头指标第二种用法是观察价格与势头的背离现象。这一理论的基础是,唯有隐含的势头存在,市场价格的变化才能被视为有效。例如,当价格持续出现新高时,只有其背后的势头也跟着出现新高,这种新高的价格才能稳住,否则所谓的背离现象便出现。背离现象在外汇市场频繁出现,价格通常也会跟随势头的逆转而逆转。 不过,在现实中,背离现象即使经常在趋势市场出现,价格却未明显逆转,使得原有的趋势仍然有效,而且价格最后还是加速随着趋势方向变化,连势头也再度反转顺着趋势,使得根据背离讯号逆向操作的交易无利可图。这也就是说,背离现象可以产生许多假讯号,导致没有注意到趋势指标的交易者作出许多错误的交易