短线王主图指标公式

问:求通达信主图指标公式

X0:=BACKSET(REF(C,3)<MA(C,3) AND REF(V,3)>MA(V,3) AND REF(C/REF(C,1)>1.03 AND C>O,3),4);

X1:=X0 AND REF(X0,1)=0;

STICKLINE(X1,H,C,0,0),COLORFF0080;

STICKLINE(X1,O,C,3,0),COLORFF0080;

STICKLINE(X1,L,O,0,0),COLORFF0080;

X3:=BACKSET(LLV(L,3)>REF(C,3) AND REF(X1,3),4);

STICKLINE(X3,REF(C,BARSLAST(X1)),REF(C,BARSLAST(X1)),5,0),COLORFF0080;

X5:=BACKSET(LLV(L,3)<REF(O,3) AND REF(X1,3),4);

STICKLINE(X5,REF(L,BARSLAST(X1)),REF(L,BARSLAST(X1)),5,0),COLORFF0080;

问:通达信超赞的主图指标公式是怎样的

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.03,0,EXTERNSTR(0,3)),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,EXTERNSTR(0,6)),COLORLIBLUE;
DRAWTEXT_FIX(ISLASTBAR,0,0.09,0,EXTERNSTR(0,12)),COLORLIGREEN;{老王}
DRAWTEXT_FIX(ISLASTBAR,0,0.15,0,FGBLOCK),COLORLIMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,EXTERNSTR(0,1)),COLORYELLOW;{融胜}
主力成本线:EMA(COST(9),250),COLORBROWN,DOTLINE;
{牛马线买点公式升级版}
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
马线:MA(牛线,8),COLORWHITE;
DRAWICON( FILTER(CROSS(牛线,马线),20),马线-0.002 ,1);
DRAWTEXT(CROSS(牛线,马线),LOW*0.984,'买'),COLORRED,LINETHICK2;
止损价:H*0.95,LINETHICK0.5,COLORRED;
庄家:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
IF(庄家>=REF(庄家,1),庄家,DRAWNULL),COLORRED,LINETHICK4;
IF(庄家<=REF(庄家,1),庄家,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWBAND(牛线,RGB(255,87,22),马线,RGB(0,30,255));
MA60:MA(CLOSE,60),COLORGRAY;
N1:=10;
TK:=CONST(HHVBARS(V,10)),COLOR0000FF,LINETHICK1;
量能平台:IF(CURRBARSCOUNT<=N1+3,CONST(IF(TK=0,C,REF(C,TK))),DRAWNULL),COLORGRAY,LINETHICK1;
NOTEXT_新量能点:IF(CURRBARSCOUNT=TK+1,量能平台,DRAWNULL),CIRCLEDOT,COLORFFFFFF,LINETHICK9;
DRAWTEXT(ISLASTBAR,量能平台,'量能平台'),COLORGRAY;
{稳涨}
红轨道:=MA(MA(CLOSE,3),1),LINETHICK1,COLORYELLOW;
轨道:MA(MA(CLOSE,3),3),COLOR32CD32,LINETHICK2;
NOTEXT_升:IF(红轨道>=轨道,轨道,DRAWNULL),COLORMAGENTA,LINETHICK2;
机构:(L2_VOL(0,0) - L2_VOL(0,1))*10000/FINANCE(7),NODRAW,COLORRED;
大户:(L2_VOL(1,0) - L2_VOL(1,1))*10000/FINANCE(7),NODRAW,COLORMAGENTA;
主力:机构+大户,NODRAW,COLORYELLOW;
STICKLINE(主力>0,O,C,1.5,1),COLORRED;
STICKLINE(主力<0,O,C,1.5,1),COLORCYAN;
STICKLINE(大户>0,O,C,1,0),COLORMAGENTA;
STICKLINE(大户<0,O,C,1,0),COLORGREEN;
STICKLINE(机构>0 AND 大户>0,O,(O+C)/2,1,0),COLORRED;
STICKLINE(机构<0 AND 大户>0,C,(O+C)/2,1,0),COLORCYAN;
STICKLINE(机构>0 AND 大户<0,O,(O+C)/2,1,0)COLORMAGENTA;
STICKLINE(机构<0 AND 大户<0,C,O,1,0)COLORLICYAN;
累计:=SUM(主力,30),COLORMAGENTA;
均值:=EMA(累计,MIN(10,30)),COLORWHITE;
{红}
STICKLINE(CROSS(累计,均值),H,L,0,0),COLORRED,LINETHICK1;
STICKLINE(CROSS(累计,均值),CLOSE,OPEN,1.4,0),COLOR000088;
STICKLINE(CROSS(累计,均值),CLOSE,OPEN,1,0),COLOR0000BB;
STICKLINE(CROSS(累计,均值),CLOSE,OPEN,0.6,0),COLOR0000DD;
STICKLINE(CROSS(累计,均值),CLOSE,OPEN,0,0),COLOR0000FF;
{蓝}
STICKLINE(CROSS(均值,累计),H,L,0,0),COLORFF8800,LINETHICK1;
STICKLINE(CROSS(均值,累计),CLOSE,OPEN,1.4,0),COLORBB4400;
STICKLINE(CROSS(均值,累计),CLOSE,OPEN,1,0),COLORCC5500;
STICKLINE(CROSS(均值,累计),CLOSE,OPEN,0.6,0),COLORDD6600;
STICKLINE(CROSS(均值,累计),CLOSE,OPEN,0,0),COLOREE7700;
{高低点定位}
G0:=(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))+XMA(XMA(H,30),30);
D0:=XMA(XMA(L,30),30)-(XMA(XMA(H,30),30)-XMA(XMA(L,30),30));
G01:=(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))*0.5+XMA(XMA(H,30),30);
D01:=XMA(XMA(L,30),30)-(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))*0.5;
GO0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60);
DO0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3;
STICKLINE(CURRBARSCOUNT=1,G0,G0,100,5),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,D0,D0,100,5),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=1,GO0,GO0,100,5),COLORLIBLUE;
STICKLINE(CURRBARSCOUNT=1,DO0,DO0,100,5),COLORRED;
DRAWTEXT(ISLASTBAR,G0,'卖'),COLORGREEN;
DRAWTEXT(ISLASTBAR,D0,'买'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,GO0,'顶'),COLORLIBLUE;
DRAWTEXT(ISLASTBAR,DO0,'底'),COLORRED;
由于公式字符过多,这里限制数量无法发出,

问:短线高手主力版“买卖趋势”指标公式源码

非常准的趋势买卖(图片演示在下面网址里)

VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'B'),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'S'),COLORGREEN;

绿上卖,红下买。

问:超级短线王指标公式怎样添加到博易大师里用?

先点击专家系统,在点击里面的公式管理器------------其他类型---------新建-----复制源码再点击确定就可以了

问:下面通达信 选股公式 改为副图指标能看的,谢谢!

这个很简单,你在技术指标公式里选择其他类型,然后新建个公式,把你贴出来的代码复制进去即可,在新建议公式时要注意一下画线方法选择“副图”就行了。如果你想让哪个数据显示出来那你就把那个=号去掉就行。
如果不会弄或是有任何问题,也可以加我Q我帮你弄,欢迎交流。
望采纳。

问:请高手帮忙把一个副图指标做一个通达信条件预警公式

VAR1:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR2:=EMA(VAR1,30);
VAR3:=2*(VAR1-VAR2)*10;
VAR4:=POW(VAR3,3)*0.1+POW(VAR3,2);
VAR6:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR7:=EMA(VAR6,100);
VAR8:=2*(VAR6-VAR7);
VAR9:=POW(VAR8,3)*0.1+POW(VAR8,1);
CROSS(VAR3,0.015) OR CROSS(VAR8>0.1,VAR9);